$re = '/^[1-9][0-9]*$/m';
$str = '0001
1000
1
2
123123123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);