import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(TITLE-.+?-\\d{2}-\\d{2})\\S*\\s*(.*?)^Conditions.*?^Opening date (\\d{1,2} \\w+ \\d{4})\\s*?^Deadline (\\d{1,2} \\w+ \\d{4})\\s*^Indicative budget:.*?(EUR [\\d.]+ \\w+)";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam id diam posuere, eleifend diam at, condimentum justo. Pellentesque mollis a diam id consequat.\n\n"
+ "TITLE-SDFSD-DFDS-SFDS-01-01: This is the title 1 that\n\n"
+ "is split into two lines with a blank line in the middle\n\n"
+ "Conditions Pellentesque blandit scelerisque pellentesque. Sed nec quam purus. Quisque nec tellus sed neque accumsan lacinia sit amet sit amet tellus. Etiam venenatis nibh vel pellentesque elementum. Nullam eget tortor quam. Morbi sed leo et arcu aliquet luctus.\n\n"
+ "Opening date 15 Apr 2021\n\n"
+ "Deadline 26 Aug 2021\n\n"
+ "Indicative budget: The total indicative budget for the topic is EUR 20.00 million.\n\n"
+ "TITLE-SDFSD-DFDS-SFDS-01-02; This is the title2 in one single line\n\n"
+ "Conditions Cras egestas consectetur sapien at dignissim. Maecenas commodo purus nibh, a tempus augue vestibulum feugiat. Vestibulum dolor neque, sagittis ut tortor et, lobortis faucibus quam.\n\n"
+ "Opening date 15 March 2021\n\n"
+ "Deadline 17 Aug 2021\n\n"
+ "Indicative budget: The total indicative budget for the topic is EUR 15.00 million.\n\n"
+ "TITLE-SDFSD-DFDS-SFDS-01-03: This is the title3 that is too long and takes two lines\n\n"
+ "Conditions Cras egestas consectetur sapien at dignissim. Maecenas commodo purus nibh, a tempus augue vestibulum feugiat. Vestibulum dolor neque, sagittis ut tortor et, lobortis faucibus quam.\n\n"
+ "Opening date 15 May 2021\n\n"
+ "Deadline 26 Sep 2021\n\n"
+ "Indicative budget: The total indicative budget for the topic is EUR 5.00 million.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}