package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[#&][^ \a]{0,200}$`)
var str = `#america`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}