package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z\d ]+:[ ,A-Z\d]+`)
var str = `amount:2 price:253,18 price2:59,24 EU status:WBB NAS MRR OWA PXA min:1 opt:3 category: PNE code z:195750`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}