$re = '/^[A-Za-z]+(?:[- ][A-Za-z]+)*$/m';
$str = '-Something
Something-
Something-Something-
Something
something-Something
Something-Something-Something
S-o-m-e-t-h-i-n-g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);