package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)] (.*?)(?:\[|$)`)
var str = `[A] Assam[B] Meghalaya[C] West Bengal[D] Odisha`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}