use strict;
my $str = 'Sabrina Green,802-867-5309,System Administrator';
my $regex = qr/,(?=\d)/mp;
my $subst = ',+1-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";