re = /(\((?>[^()]+|(?1))*\))|(\w+)/m
str = 'if ((a and b) or (a and)) or (c and d) or (e and f)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end