$re = '/(^[ ]*([-]{1}[ ]{1}){0,1}hello:: )(.*$)/m';
$str = '- hello:: asdasdsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);