re = /(?i)[a-z][0-9]{3}-[0-9]{3}(?:[a-z][0-9]{4}){2}/m
str = 'I123-123S1234N1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end