$re = '/.*?-[Ff]iltered/';
$str = 'Filtered
qqqFiltered
Filteredqqq
filtered
qqqfiltered
this-filtered
wow-Filtered
fff-filtered-qq
nope-Filtered-ok
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);