const regex = /(?<=attrs={|,)([^:}]*):([^:},]*)(?=}|,)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=attrs={|,)([^:}]*):([^:},]*)(?=}|,)', 'gs')
const str = `this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}