$re = '/(?!\'.*\')\b[\w\']+\b/';
$str = 'dello my ear olke rurpno ⭐️{2b50} aeu- o--o//o li\'eos⭐️';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);