$re = '/[^,]*,[^,]*,[^,]*/U';
$str = 'Berlin, Germany
Gitschiner Straße 1, Berlin, Germany
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);