import re
regex = re.compile(r"(?'cislo_riadku'\d+)?[\t]?(?'nazov_polozky'[^\t]+)?[\t]?(?'pocet_kusov'\d+)?[\t]?(?'merna_jednotka'\w+)?[\t]?(?'jednotkova_cena'\d+\.\d+)?[\t]?(?'suma_bez_dph'\d+\.\d+)?[\t]?(?'dph'\d+%)?[\t]?(?'suma_s_dph'\d+\.\d+)?\n")
test_str = ("14 Práce - 1NP - Rack \"A\" - skladové priestory LAN\n"
"15 motáž krabice do sadrokartónu 6 ks 6.000 36.00 20% 43.20\n"
"16 montáž žľabu 40/20 14 m 1.000 14.00 20% 16.80\n"
"17 montáž káblu FTP 1450 m 0.500 725.00 20% 870.00\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")