import re
regex = re.compile(r"^.*(?=\nOUTRAS INFORMAÇÕES)", flags=re.MULTILINE)
test_str = ("NOME: TESTE DE SILVA SAURO\n"
"CPF: 785.981.970-84\n"
"DECLARAÇÃO DE AJUSTE ANUAL\n"
"IMPOSTO SOBRE A RENDA - PESSOA FÍSICA\n"
"EXERCICIO 2018 ANO-CALENDÁRIO 2017\n"
"EVOLUÇÃO PATRIMONIAL\n"
"Bens e direitos em 31/12/2016\n"
"Bens e direitos em 31/12/2017\n"
"Dividas conus rcais em 31/12/2016\n"
"Divisas e ônus reais em 31/12/2017\n"
"100.580.873.91\n"
"100.329. 110,32\n"
"9135,456,07\n"
"8.571.962,06\n"
"OUTRAS INFORMAÇÕES\n"
"Rendimentos isentos e não tributáveis")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")