re = /^\/[*\/]{1}|#|'{3}/m
str = '/*Hello world */
#Hello world
//Hello world
\'\'\'Hello world
/Hello world
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end