$re = '/\s+(?=\w+\=)/m';
$str = 'p1=a b c p2=d e f g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);