package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\n?)\s*#{1,6}\s+| *(?:(\n)\s*)?#* *(?:(\n)\s*)?$`)
var str = `## aaa bbb`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}