import Foundation
let pattern = #"https:\/\/\S+\/[a-z-0-9\?=]+-+\d+-+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"nav="true">Upgrade</a></div></div></header><div class="js-streamItemList"><div class="streamItem streamItem--readingListPostItem js-streamItem"><section class="u-paddingTop20 u-paddingBottom20 u-borderBottomLightest u-maxWidth740"><div class="u-flexTop"><div class="u-flex1 u-width560"><a class="link link--noUnderline u-baseColor--link" href="https://becominghuman.ai/exporting-cassandra-time-series-data-to-s3-for-data-analysis-using-spark-ca9337990a21?source=bookmarks---------0---------------------"><h3 class="u-paddingTop4 u-contentSansBold u-fontSize22 u-textColorDarkest u-maxHeight2LineHeightTighter u-lineClamp2 u-textOverflowEllipsiadingTime" title="6 min read"></span></div></div><a class="link link--noUnderline u-baseColor--link" href="https://becominghuman.ai/exporting-cassandra-time-series-data-to-s3-for-data-analysis-using-spark-ca9337990a21?source=bookmarks---------0---------------------"><div class="u-flex0 u-width80 u-marginLeft40" style="height: 80px; background-image: url("https://cdn-images-1.medium.com/fit/c/72/72/1*s-_xasoH65yaxSWqmezjTA.png"); background-position: 50% 50% !import1 u-width560"><a class="link link--noUnderline u-baseColor--link" href="https://hackernoon.com/how-to-create-simple-rest-apis-with-springboot-79148ac90efd?source=bookmarks---------1---------------------"><h3 class="u-paddingTop4 u-contentSansBold u-fontSize22 u-textColorDarkest u-maxHeight2LineHeightTighter u-lineClamp2 u-textOverflowEllipsis u-patime datetime="2019-01-25T23:07:22.508Z">Jan 26</time><span class="middotDivider u-marginLeft3 u-marginRight3"></span><span class="readingTime" title="7 min read"></span></div></div><a class="link link--noUnderline u-baseColor--link" href="https://hackernoon.com/how-to-create-simple-rest-apis-with-springboot-79148ac90efd?source=bookmarks---------1---------------------"><div class="u-flex0 u-width80 u-marginLeft40" style="height: 80px; background-image: url("https://cdn-images-1.medium.com/fit/c/72/72/0*3WmoDj3kwKL3koI6"); background-position: 50% 50% !important;"><span class="u-textScreenReader">How to create simple rest apis with springboot</span></div></a></div><ul class="u-flexCenter u-fontSize14 u-textColorNormal"><li><button class="button button--chromeless u-baseColor--buttonNormal" data-action="remove-from-queue">Remove</button></li></ul></section></div></div></div></div></div></div>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)