const regex = /(^(([a-z]+)([-][a-z]+)*)$)/iu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(([a-z]+)([-][a-z]+)*)$)', 'iu')
const str = `my-button`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}