import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(52.\\d{3}(-\\d*)?)(\\s?)((([\\w\\W]*?\\.)(\\s*?)(\\w[\\s\\S]*?)(\\s*?)(\\(End of (clause|provision)\\)))|(\\[Reserved\\]))";
final String string = "52.209-6Protecting theGovernment’s Interest WhenSubcontracting withContractorsDebarred, Suspended, or Proposedfor Debarment.\n"
+ "As prescribed in 9.409, insert the following clause:\n"
+ "PROTECTING THE GOVERNMENT’S INTEREST WHEN SUBCONTRACTING WITH CONTRACTORS DEBARRED, SUSPENDED, OR PROPOSED FOR DEBARMENT (OCT 2015)\n"
+ "(a) Definition.“Commercially available off-the-shelf (COTS)” item,as used in this clause(\n"
+ "1) Means any item of supply (including construction material) that is(\n"
+ "i)Acommercial item (as defined in paragraph(1)of the definition in FAR 2.101);\n"
+ "(ii) Sold in substantial quantities in the commercial marketplace; and\n"
+ "(iii) Offered tothe Government, under a contract or subcontract at any tier, without modification, in the same form in which it is sold in the commercial marketplace; and\n"
+ "(2) Does not include bulk cargo, as defined in 46 U.S.C. 40102(4), such as agricultural products and petroleum products.\n"
+ "52.2-49\n"
+ "52.209-7 FEDERAL ACQUISITION REGULATION\n"
+ "(b)\n"
+ "The Government suspends or debarsContractors to protect the Government’s interests. Other than a subcontract for a commercially available off-the-shelf item, the Contractorshallnot enter into any subcontract, in excessof $35,000 with a Contractor that is debarred, suspended, or proposed for debarment by any executive agency unless there is a compelling reason to do so.\n"
+ "(c)\n"
+ "The Contractor shall require each proposed subcontractor whose subcontract will exceed $35,000, other than a subcontractor providing acommercially available off-the-shelfitem, todiscloseto the Contractor, inwriting, whether as of thetime ofaward of thesubcontract, the subcontractor, or itsprincipals,is or is not debarred,suspended, orproposed for debarment by the Federal Government.\n"
+ "(d)\n"
+ "A corporate officer or a designeeof the Contractor shall notify the Contracting Officer, in writing, beforeentering into a subcontract witha party (other than a subcontractor providinga commercially available off-the-shelf item) that is debarred, suspended, or proposed for debarment (see FAR 9.404 for information on the System for Award Management (SAM) Exclusions). The notice must include the following:\n"
+ "(1)\n"
+ "The name of the subcontractor.\n"
+ "(2)\n"
+ "The Contractor’s knowledge of the reasons for the subcontractor being listed with an exclusion inSAM.\n"
+ "(3)\n"
+ "The compelling reason(s) for doing business with the subcontractor notwithstanding its being listed with an exclusion in SAM.\n"
+ "(4)\n"
+ "The systems and procedures the Contractor has established to ensure that it is fully protecting the Government's interests whendealing with such subcontractor in view of the specific basisforthe party’sdebarment,suspension, or proposed debarment.\n"
+ "(e)\n"
+ "Subcontracts. Unless this is a contract for the acquisition of commercial items, the Contractor shall include the requirements of this clause, including this paragraph (e) (appropriately modified for the identification of the parties), in each subcontract that(\n"
+ "1)\n"
+ "Exceeds $35,000 in value; and\n"
+ "(2)\n"
+ "Is not a subcontract for commercially available off-the-shelfitems.\n"
+ "(End of clause)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}