package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/([^\/\n]*)){7}`)
var str = `E:/R_Process/R_Input_UDM//Greater Europe/CEW Hub/Austria/Toothpaste/Variant Data/AUSTRIA_SHG_VARIANT_8.csv'
E:/R_Process/R_Input_UDM//Greater Europe/CEW Hub/Austria/ManualTB/Variant Data/AUSTRIA_SHG_VARIANT_7.csv'
E:/R_Process/R_Input_UDM//Greater Europe/CEW Hub/Austria/MouthWash/Variant Data/AUSTRIA_SHG_VARIANT_9.csv'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}