$re = '/\b/m';
$str = 'this is a test for word boundry. Here is a trick : -12 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);