$re = '/(?<=0)1{5}(?=0)/m';
$str = '02011111020
00211111200
00111111100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);