#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bCURRENT\s*DATE\b"
Local $sString = "* RNN_FECULACT = CURRENT DATE" & @CRLF & _
                ""
Local $sSubst = "SYSDATE"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)