# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^( {3})+"
test_str = (" EMPTY_CNT :\n"
" for i in 0 to C_DESCRIPTOR_NUM - 1 loop\n"
" if r.descriptor_array(i).descriptor_state = S_READ_TO_DUMP then\n"
" v.dump_in_progress_cnt := v.dump_in_progress_cnt + 1;\n"
" end if;\n"
" end loop; -- i\n\n"
"entity descriptor_manager is\n"
" port (\n"
" i_clk : in std_logic;\n"
" i_rst : in std_logic;\n"
" i_desc_mngr : in t_i_desc_mngr;\n"
" o_desc_mngr : out t_o_desc_mngr;\n"
" -- c/s registers\n"
" cr_descriptor_select : in std_logic_vector(31 downto 0);\n"
" cr_descriptor_data : out std_logic_vector(31 downto 0);\n"
" fsm_descriptor_ctrl_status : out std_logic_vector(31 downto 0);\n"
" fsm_event_handler_status : out std_logic_vector(31 downto 0)\n"
" );\n"
"end entity descriptor_manager;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.