using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*?):((?:(?!.*:)[\d\D])*)";
string input = @" test1:
Some random
multiline text herexxx
test2:
another multiline
Textxxx
value124:
again random Text
In multiple
linesxxx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}