$re = '/^this(?!.*notthis).*$/m';
$str = 'thisnotthis
thistest
this notthis';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);