re = /(?<t>(?!\_\_)*)(\_\_(?<u>(?!\_\_)*))?(\_\_(?<v>(?!\_\_)))/m
str = 'AppSettings__Envionment__Other'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end