# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^START(.|\n)*?((?=^START)|END_OF_MSG)"
test_str = ("HELLO\n"
"START ABC DEF GHI JKL\n"
"QWER RANDOM TEXT 213%@#!\n"
"UIOP RANDOMZXCVB123456\n"
"START ABC DEF GHI JKL\n"
"ZZZZZ RANDOMTEXT213%@#!\n"
"11111 RANDOMZXCVB123456\n"
"$$$$$$ SOMEMORETEXT\n"
"START ABC DEF GHI JKL\n"
"QWER RANDOMTEXT213%@#!\n"
"$$$$$ RANDOMZXCVB123456\n"
"END_OF_MSG")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.