re = /(z-index)(.*[:]*)(-1)/
str = 'z-index: -1;
z-index: 1;
z-index: 10;
z-index: -1;
z-index: -1;
z-index:-1;
z-index: 9;
z-index : -1;
z-index : -1;
z-index : -1;
-- z-index: -1;
/* z-index : -1; */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end