re = /\.(?!a)(s?[ac]ss)$/m
str = '.scss
.sass
.css
.ass
How would I make it not match .ass?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end