// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:microsoft )?(?:win|windows)(?:[ ]| server )?(?:2003|2008|2012|2019|2016)(?: r2)?(?: std)?)$").unwrap();
let string = "microsoft windows 2016
win2016
win2012
windows 2012
windows server 2012
windows server 2008 r2
windows server 2008
windows 2019
windows 2012 r2 std
win2003
windows server 2003
windows 2003";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}