import re
regex = re.compile(r"(?:^|\s)[0-9]+\.[0-9.]*(?=\s|$)", flags=re.MULTILINE)
test_str = "lorum3 ipsum 15.2.3.9.7 bar foo 1. v more text 46 2. here and even more text here v7.8.989 and also 1.2.3c as well"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)