const regex = /^(\d+\.)\s(\w+(?:\s+[\w,]+)*)(?:[.\s]+\.(\d+(?:[.,]\d+)*)){12}+[.\s]*$/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+\\.)\\s(\\w+(?:\\s+[\\w,]+)*)(?:[.\\s]+\\.(\\d+(?:[.,]\\d+)*)){12}+[.\\s]*$', 'gms')
const str = `1. Reserve December 31, prior year.................................................................................................................. ..4,587,658,997 .......................... .1,030,275,014 .....136,963,988 .......................... .3,276,184,545 .....144,235,450 .......................... .......................... .......................... .......................... ............................................................................................................................................ ..4,587,658,997 .......................... .1,030,275,014 .....136,963,988 .......................... .3,276,184,545 .....144,235,450 .......................... .......................... .......................... .......................... ............................................................................................................................................ ..4,587,658,997 .......4,587,658,997`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}