import re
regex = re.compile(r"(?<=cu sediul [iî]n)(.*?)(?=,)", flags=re.IGNORECASE | re.DOTALL)
test_str = ("CONTRACT DE IPOTECA MOBILIARA nr. CIM/1 \n"
" \n"
"Acest Contract de Ipoteca Mobiliara a fost incheiat la data de 07/05/2018 , in baza Codului Civil, Cartea a V-a, Titlul XI, intre: \n"
" \n"
"(1) BANCA ROMANO-AMERICANA , cu sediul in Bucuresti , Calea Dorobantilor, nr. 2222 , Sector 1 , inregistrata la Registrul Comertului sub nr. J40/111/2019 , cod unic 1231213123 , denumita in continuare \"Banca\", reprezentata in prezentul contract prin Coordonator Servicii Clienti, şi Ofiter Vanzari Produse Bancare, in calitate de CREDITOR \n"
" \n"
"Si \n"
" \n"
"(2) Dna. SALA CRISTIANA , domiciliata in MUN. ARAD , STR. FARANUME, NR. 3, AP. 1 , JUD. ARAD , identificata cu CNP 111111111111111 , C.I. seria si nr. XX 22222 , eliberat de SPCLEP ARAD, la data de 01.01.2000, in calitate de GARANT, \n"
" \n"
"denumiti fiecare si impreuna „Garant”, în urmatoarele conditii: \n"
" \n"
"1. Pentru garantarea plăţii şi îndeplinirii în intregime a obligatiilor in baza Contractului de Credit nr. 2 din data de 07/05/2018 incheiat intre SALA CRISTIANA, in calitate de Imprumutat si Banca, cu modificarile ulterioare („Contractul de credit”) pana la concurenta sumei principale imprumutate de 4.184,00 LEI (patrumiiunasutaoptzecisipatru,00 LEI), plus dobanzile, dobanzile majorate/penalizatoare, costurile si spezele bancare aferente precum si a oricaror alte sume datorate sau potential datorate Bancii in baza Contractului de credit, Garantul constituie in favoarea Băncii urmatoarele ipoteci mobiliare: \n"
" \n"
" \n"
"1.1. Ipoteca mobiliara asupra soldurilor creditoare prezente şi viitoare in lei si in valuta ale conturilor curente ale dnei. SALA CRISTIANA, identificat in evidentele Bancii cu cod unic de client nr. 013161512, deschise la Alpha Bank Romania SA si carora le corespund codurile IBAN RO19BUCU1011406710983RON , inclusiv orice alte conturi asociate codului unic de client ce vor fi deschise/vor inlocui conturile identificate, precum şi asupra tuturor drepturilor cu privire la aceste sume. In cazul conturilor ce vor fi deschise/vor inlocui conturile identificate in prezentul Contract, deschiderea unui nou cont va fi considerata ca incluzand acordul Garantului cu privire la extinderea ipotecii asupra acestui nou cont, fara a mai fi necesara incheierea unui act aditional in acest sens. Banca va furniza Garantului o lista actualizata cu conturile deschise la Banca, iar aceasta lista va constitui dovada ipotecarii noilor conturi. In cazul in care Garantul solicita deschiderea un nou cont, Banca are dreptul sa conditioneze deschiderea contului de incheierea unui act aditional la prezentul contract de ipoteca, in masura in care considera necesar in vederea protejarii drepturilor sale rezultand din prezentul contract. Garantul se obliga să nu retragă sau să efectueze vreo plată din conturile supuse ipotecii fără acordul prealabil al Băncii, in cazul in care Banca solicita astfel. In cazul in care, pe parcursul derularii creditului, clientul opteaza pentru un alt tip de cont, schimbare care va conduce la inlocuirea nr. de cont, Banca este autorizata de Garant sa efectueze formalitatile de publicitate necesare la Arhiva Electronica de Garantii Reale Mobiliare, Garantul suportand costurile aferente acestora. Publicitatea prezentei ipoteci mobiliare se realizeaza si prin controlul exercitat de Banca asupra conturilor Clientului in conformitate cu dispozitiile art. 2410 Cod civil. Banca are dreptul să execute ipoteca mobiliară utilizând orice procedură in conditiile legii, Banca urmand a alege modalitatea cea mai profitabila pentru recuperarea creantei sale, inclusiv (dar fara a se limita la) debitarea soldurilor conturilor ipotecate. \n"
" \n"
"1.2. Ipoteca mobiliara asupra venitului net lunar al dnei. SALA CRISTIANA pana la concurenta a o treime (1/3) din salariu si din alte venituri periodice realizate din munca sau din activitatile sale profesionale, civile sau comerciale, incluzand, dar fara a se limita la dividende, participatii la profit, chirii. Garantul imputerniceste prin prezentul contract Banca sa notifice debitorilor creantei ipotecate prezenta ipoteca mobiliara, cu mentiunea ca plata datorata de acestia rezultand din venituri ale Garantului, periodice, realizate din munca sau din activitatile profesionale, civile sau comerciale, incluzand dar fara a se limita la dividende, participatii la profit, chirii se va efectua in contul ce va fi indicat de catre Banca in notificarea transmisa debitorului creantei ipotecate, la libera alegere a Bancii si cu instructarea corespunzatoare a debitorului creantei ipotecate. Banca isi rezerva dreptul de a schimba modalitatea de plata a creantelor, in temeiul art. 2406 Cod civil. Garantul se obliga sa nu efectueze nicio operatiune de compensare, novare, respectiv orice alt mod de stingere a creantelor ipotecate care fac obiectul prezentului contract. Garantul recunoaste irevocabil si neconditionat dreptul deplin al Bancii asupra creantelor ipotecate, precum si dreptul deplin al acesteia de a utiliza sumele ipotecate pentru acoperirea obligatiilor de plata si a tuturor cheltuielilor ce sunt in sarcina Garantului, corespunzator clauzelor din prezentul contract si din Contractul de Credit, si abiliteaza Banca sa îi debiteze conturile la scadenta sau oricand pe perioada derularii facilitatii de credit in vederea recuperarii creantei sale decurgand din Contractul de Credit. \n"
" \n"
"2. În conformitate cu art. 2392 Cod civil, ipotecile mobiliare constituite prin prezentul Contract se extind şi asupra fructelor şi productelor bunurilor mobile ipotecate, precum şi asupra tuturor bunurilor primite de Garant în urma unui act de administrare ori de dispoziţie încheiat cu privire la bunurile mobile ipotecate. Se consideră, de asemenea, a fi produse ale bunurilor mobile ipotecate orice bunuri care le înlocuiesc sau în care trece valoarea acestora. \n"
"3. Garantul declara că a luat cunoştinţă de conţinutul Contractului de credit, pe care l-a înţeles şi acceptat, şi care îi este astfel opozabil. \n"
"4. Ipotecile mobiliare constituite prin prezentul contract sunt garantii continue si se vor intinde pana la ultima plata a sumelor datorate de catre Imprumutat in baza Contractului de credit, indiferent de orice plata sau indeplinire intermediara, totala sau partiala. \n"
"5. Garantul declară şi garantează Băncii (i) că a întreprins toate acţiunile necesare pentru a asigura că ipotecile mobiliare constituite prin prezentul contract reprezintă obligaţii valabile din punct de vedere legal ale Garantului, care pot fi puse în executare în conformitate cu termenii prezentului contract, (ii) că bunurile ipotecate sunt în proprietatea sa deplină, că are titlu valabil asupra acestora şi că aceste bunuri sunt bine conservate (iii) că bunurile afectate ipotecii sunt libere de orice sarcini (cu excepţia prezentelor ipoteci), (iv) că nicio persoana nu are dreptul de a formula vreo pretenţie cu privire la dreptul de proprietate, folosinţă sau posesie asupra bunurilor ipotecate, (v) că nu a fost început niciun litigiu sau orice alta procedură judiciară sau administrativă cu privire la titlul de proprietate al Garantului asupra bunurilor ipotecate, (vi) că, de la momentul înregistrării prezentelor ipoteci mobiliare, Banca va avea un drept de prioritate de rang I asupra bunurilor ipotecate. Declaratiile si garantiile conţinute în prezentul Contract vor fi considerate a fi reconfirmate de catre Garant in fiecare zi pana la data indeplinirii in intregime a obligatiilor garantate prin prezentul contract, cu privire la circumstantele existente la momentul respectiv. \n"
"6. Garantul se obligă faţă de Bancă (i) sa informeze in prealabil Banca si sa solicite acordul acesteia cu privire la constituirea oricarei sarcini asupra bunurilor ipotecate, in favoarea altui creditor. Garantul nu va putea constitui o noua sarcina asupra bunurilor ipotecate fara consimtamantul expres al Bancii, daca prin aceasta ar fi afectat rangul ipotecilor constituite prin prezentul contract ori ar fi vatamate in orice alt mod interesele Bancii, (ii) să nu transfere niciun drept cu privire la bunurile ipotecate, (iii) sa nu intreprinda nimic care sa impiedice Banca in realizarea drepturilor sale in baza prezentului Contract; (iv) sa conserve valoarea bunurilor ipotecate si sa anunte Bancii aparitia oricarei situatii care ar putea determina diminuarea si/sau modificarea in orice sens a valorii acestora sau orice alta situatie care priveste direct interesele Bancii fata de ipotecile mobiliare constituite prin prezentul contract. \n"
" \n"
"7. Garantul se obligă să semneze şi să puna la dispoziţie toate actele sau înscrisurile şi să întreprindă toate acţiunile ce vor fi solicitate de Banca pentru (i) perfectarea sau conservarea ipotecilor create prin prezentul contract; (ii) conservarea sau protejarea tuturor drepturilor Bancii din prezentul contract şi/sau (iii) facilitarea executării ipotecilor sau a oricărei părţi din acestea sau exercitarea oricărui drept, facultate sau autoritate cu care Banca este învestita în baza prezentului contract, în oricare dintre aceste cazuri imediat după cererea Bancii şi pe cheltuiala Garantului. \n"
"8. Ipotecile mobiliare constituite prin prezentul contract acorda Bancii dreptul ca, pe durata valabilitatii prezentului contract, sa verifice oricand existenta obiectului ipotecilor descris mai sus, iar in cazul in care constata lipsa diligentei in conservarea valorii bunurilor afectate ipotecii, sa solicite pe cale judecatoreasca luarea masurilor asiguratorii. Banca are dreptul de a considera ca obligatia garantata a devenit exigibila si de a trece la urmarirea silita, in conditiile legii, in cazul in care constata lipsa unei intretineri corespunzatoare a bunurilor ipotecate sau alte fapte de natura sa ingreuneze sau sa faca imposibila urmarirea silita. \n"
"9. Banca va înregistra prezentele ipoteci mobiliare la Arhiva Electronica de Garantii Reale Mobiliare, conform dispozitiilor art. 2413 si urmatoarele din Codul civil, toate spezele privind incheierea si inregistrarea/asigurarea publicitatii, modificarea prezentului contract fiind in sarcina Garantului. Banca va pune la dispozitia Garantului, in mod gratuit, la ghiseele sale, o copie a avizului de inscriere a ipotecilor mobiliare in Arhiva Electronica de Garantii Reale Mobiliare, in conformitate cu prevederile legale. \n"
" \n"
"10. Drepturile Băncii conferite de legea română unui creditor garantat cu garanţii reale mobiliare, astfel cum acestea sunt modificate şi/sau extinse prin prezentul contract, se nasc la semnarea prezentului contract şi vor putea fi puse în executare de către Bancă în orice moment în legatura cu oricare parte a bunurilor ipotecate la apariţia unui caz de neexecutare conform Contractului de credit. \n"
"11. Banca are dreptul să execute ipoteca mobiliară constituită prin prezentul contract utilizând orice procedură in conditiile legii, Banca urmand a alege modalitatea cea mai profitabila pentru recuperarea creantei sale, urmarindu-se acoperirea integrala a datoriilor catre Banca. In caz de executare silita a bunurilor afectate garantiei, toate cheltuielile, spezele, precum si toate sumele ramase neacoperite prin valorificarea acestora sunt si ramân in sarcina Garantului. \n"
"12. Garantul renunta in mod expres si irevocabil la orice drept de a invoca orice discutiune sau exceptie cu privire la urmarirea bunurilor ipotecate si confirma ca Banca va avea deplina libertate de a urmari orice bun dupa cum va considera necesar sau oportun pentru acoperirea integrala a sumelor datorate. \n"
"13. Atât Banca, cât şi mandatarii, administratorii, funcţionarii, angajaţii, delegaţii şi consultanţii acesteia, nu vor fi răspunzători pentru nici o pretenţie, cerere, obligaţie, pierdere, prejudiciu, costuri sau cheltuieli suportate sau apărute în legătură cu exercitarea sau potenţiala exercitare sau omisiunea de a exercita oricare dintre drepturile şi puterile dobândite conform prezentului contract, cu excepţia cazului în care prejudiciul a fost cauzat cu intenţie sau din culpă gravă, constatata prin hotarare judecatoreasca definitiva si executorie. \n"
"14. Prezentul contract de ipotecă mobiliară constituie titlu executoriu conform legislatiei bancare şi conform art. 2431 Cod Civil. \n"
"15. Prezentul contract este guvernat de legea română. Litigiile de orice natura izvorate din prezentul contract ori in legatura cu acesta se vor solutiona de instantele judecatoresti competente conform legii/ conventiei partilor. \n"
"16. Prezentul contract intra in vigoare la data semnarii lui si isi inceteaza valabilitatea la data platii integrale a tuturor obligatiilor fata de Banca, obligatii decurgand din Contractul de credit prevazut la articolul 1. \n"
"17. Prezentul contract este accesoriu al Contractului de credit mentionat in articolul 1, intra in vigoare la data semnarii lui si isi inceteaza valabilitatea la data platii integrale a tuturor obligatiilor fata de Banca decurgand din Contractul de credit. \n"
"Prezentul contract s-a incheiat astazi 07/05/2018, in 2 (doua) exemplare originale, din care un singur exemplar pentru Banca si cate un exemplar pentru celelalte parti. \n"
" \n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")