package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]*(?:[^0-9a-z][0-9]*)*$`)
var str = `01230.123.1032,1032`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}