#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\d{10}) {6}\t(\d{10})\b(?=[\s\S]*\b\1 {6}\t\2)\b"
Local $sString = "+----------------+---------------+------------+" & @CRLF & _
"| Reference Date | Instrument ID | Entity ID |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 4251675720 1000183742 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 4251675720 1000183742 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 2113750655 100065856 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 3512075270 1002923999 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 4251998103 1003890261 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 4239113350 1004043945 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 8569030255 1004043945 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 6692802619 1004584989 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 6751615521 1005048991 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 1338818134 1005076529 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 1903780287 1005519781 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 3023132803 1005535434 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 3075990149 1006443568 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 1821112520 1007165898 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 4249904989 100753094 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 4230960972 1009300504 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
"| 2019-06-28 2254190165 1010611747 |" & @CRLF & _
"+----------------+---------------+------------+" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")