re = /(.+?)\1+/
str = '123123123123
daddaddaddad
sadsadasad
sadsadsad
121212121
sasasasasas
sdsdsdsds
dsdsdsdsd
ffffffff
blahblah
ioiooioioioi
popopopopop
Hi I dont think this is a spam.
II loooovve this. It\'s awesooooommeee!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end