re = /(?ms)([0-9]+\s[A-Z][a-z].+(?=,))/m
str = '001 ALLAN Witham Ross 13 Every_Street, Welltown Greenkeeper 002 ALLARDYCE Margaret Isabel 49 Bell_Road, Musicville Housewife 003 ALLARDYCE Mervyn George 49 Bell_Road, Musicville Company Mngr '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end