$re = '/((?<!\band )|(?<=\btall and ))book/m';
$str = 'other and book
tall and book
small and book
book';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);