using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(foo|bar|baz) (*COMMIT) (?!.*(?1))";
string input = @"Fouo buar, Cambaz!";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}