import re
regex = re.compile(r"\A(?# String begin)([\*])?(?# Optional * at begin)([[:word:][:blank:][!\"#$%£¥#%@€&'()+,\-.\/:;<=>?@[\]^_`{|}~§üäöÜÄÖ]]*)(?# match characters allowed as search string - no * in here!){3,}?(?# at least 3 characters, non greedy)([\*])?(?# optional * at end)\Z(?# end of string)")
test_str = "*SomeT?=)(/&%$\"!123423AndSomeMore*"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")