const regex = /^data:([-\w]+\/[-+\w.]+)?((?:;?[\w]+=[-\w]+)*)(;base64)?,(.*)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^data:([-\\w]+\\\/[-+\\w.]+)?((?:;?[\\w]+=[-\\w]+)*)(;base64)?,(.*)', 'i')
const str = `data:image/jpeg;key=value;base64,UEsDBBQAAAAI`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}