#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b"
Local $sString = "#fff" & @CRLF & _
"#fefefe" & @CRLF & _
"#242424" & @CRLF & _
"#24ff33" & @CRLF & _
"#24ff3o // o is not a valid hex value" & @CRLF & _
"#ffg // g is not a valid hex value"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")