$re = '/(?<=\()\d+(?=\))|\d/m';
$str = '2(10)1(12)
2069
2(15)
2131';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);