$re = '/(?s)[a-z]\n(.+?)(?=[a-z])/m';
$str = 'a
111
b
222
c
333
d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);