$re = '/(?:\([^()]*\)|\w+\.?)\s•/';
$str = 'ALCOHOL DENAT. • FRAGRANCE (PARFUM) • WATER\\AQUA\\EAU • HYDROXYCITRONELLAL • LIMONENE • BENZYL BENZOATE • CITRONELLOL • GERANIOL • COUMARIN • FARNESOL • CITRAL • BENZYL ALCOHOL • CINNAMYL ALCOHOL • LINALOOL • ALCOHOL • DIPROPYLENE GLYCOL • ETHYLHEXYL METHOXYCINNAMATE • BUTYL METHOXYDIBENZOYLMETHANE • ETHYLHEXYL SALICYLATE • TRIS(TETRAMETHYLHYDROXYPIPERIDINOL) CITRATE • DILAURYL THIODIPROPIONATE • TOCOPHEROL • BHT • BENZOIC ACID • RED 4 (CI 14700) • EXT. VIOLET 2 (CI 60730) • YELLOW 6 (CI 15985) <ILN46472>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);