package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+x\d+`)
var str = `https://video.twimg.com/ext_tw_video/841791481534803968/pu/vid/320x180/egCAExYQdRBw08fb.mp4
https://video.twimg.com/ext_tw_video/841791481534803968/pu/vid/1280x720/GVsCGddpL9QoO4_B.mp4
https://video.twimg.com/ext_tw_video/841791481534803968/pu/vid/640x360/33qcUEzFw-WS0inJ.mp4
https://video.twimg.com/ext_tw_video/640x360/pu/vid/841791481534803968/33qcUEzFw-WS0inJ.mp4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}